Getting Live HTTP Headers to work with Firefox 4

UPDATE: The official Live HTTP Headers add-on now works with Firefox 4:

Download Here: http://livehttpheaders.mozdev.org/


Note this is a temporary solution, and worked for me with Firefox 4 b12:

  • Download the .xpi file (Use right-click save as or Firefox will try to install the add-on)
  • Rename .xpi to .zip
  • Unzip the contents
  • Edit install.rdf
  • Under the <–Firefox –> Section change <em:maxVersion>3.6.*</em:maxVersion> to <em:maxVersion>4.0.*</em:maxVersion>
  • Rezip the files
  • Rename it back to .xpi from .zip
  • In Firefox do file open, and open the .xpi file.

The add-on should install, just restart Firefox and use as normal.

Note: It works on my machine, however your mileage my vary.  Obviously, I recommend that you keep an eye out for an official update and install the proper version as soon as it’s available…

Join the Conversation

11 Comments

  1. Or you could just add the boolean ‘extensions.checkCompatibility.4.0b’ with value ‘false’ in about:config to stop Firefox from checking the minimum required version of an extension 😉

    1. Yep that’s certainly the easier way 🙂 Although bear in mind that it will try to run all of your old add-ons rather than just this one (incase you have an add-on that doesn’t play nice with Firefox 4).

Leave a comment

Leave a Reply to bonkers Cancel reply

Your email address will not be published. Required fields are marked *